Posted on Leave a comment

OpenAuto Pro by Bluewave Studio – Initial guide

I certainly can vouch for the quality of this product. It has worked very well for me so far. The post below from the forum I found Invaluable. If you you HallCastle05 as a discount code when you purchase the software you will get a 5% discount!

Copied from the forum

Written by an OAP newbie who spent two weekends trying to get this work. Despite the official documentation and other threads on how to do this, I have constantly failed to get it to work until recently. I documented the following which worked for me with lots of trial and error including notes on issues I’ve encountered and my solutions for those. I hope it can help others.

This was performed in OAP 7.0 on a Raspberry Pi 4 B with external USB Bluetooth, Soundcard and Microphone dongles (required).

Android Auto (AA) Phone Preparation
Open AA Settings and scroll down to Version.

Tap Version repeatedly until a pop up asks you to Enable Developer Mode — tap option to allow.

At the top right of this screen, tap the three dots and tap Developer Settings.

Enable ‘Add Wireless Projection To Settings’ and then close AA.

OpenAutoPro (OAP) Preparation
Flash OAP 7.0 to an SD Card and insert into Raspberry Pi (RPi).

Connect all the required external USB devices to the RPi: Bluetooth, Soundcard, Microphone. Without these devices connected, Android Auto will not launch on OAP.

Power up the RPi.

When OAP is booted, tap Settings then Wireless.

Under Hotspot band, tap 5GHz (for best results if supported by both your RPi and Phone) and then tap the Hotspot button above to enable it. There will be a few seconds of what seems like input lag when tapping on these buttons, give it a moment to switch WiFi modes.

Under Settings, tap AA, tap System and tap on Start Android Auto Automatically, then tap on Wireless Android Auto. I disabled Show Top Bar in Android Auto because it was annoying seeing another bar with Time, Battery, etc since AA already displays this.
Note: Enabling Hotspot on OAP will disable all existing WiFi connections previously established in Raspbian OS.

Raspbian OS (ROS) Preparation
In OAP tap the Power Button Icon at the bottom of the screen and then tap Return to minimize OAP and display the ROS Desktop.

(Optional): If this is your first time entering ROS, and are prompted, complete the initial setup. Do note that when you reach the WiFi Network screen at the end of the setup, no network will be displayed because you already enabled Hotspot in OAP. You can skip this step in the ROS setup process.

At the top-right of the ROS desktop, click on the Bluetooth Icon and then Add Device.

Pair your Phone with ROS. You may encounter an error when attempting to pair from the phone to ROS, but you may still be paired. Check the Bluetooth connections on the Phone and in ROS.

On your Phone, connect to a new WiFi Network. Look for OpenAutoPro in the WiFi list and connect with the default password: 1234567890.

For good measure, reboot your Phone and RPi.

After reboot, test AA WiFi connection. You might need to enter an IP Address the first time (like I did) before it automatically connects. Under your OpenAutoPro Hotspot connection on your Phone, tap the connection and look for the IP address. You might need to click Edit the connection to see the variables under Advanced.

Notes on Issues & Solutions

The following are some issues I had to deal with that were not obvious or covered in the official OAP documentation.
Every change I’ve made in ROS or OAP required me to reboot the system to apply these changes. I suggest doing the same on your end to prevent headaches.

Some of the ROS menus won’t display unless you use a mouse for right-click functions that enable sub menus for Bluetooth, WiFi and Sound.

In ROS you might need to set the default Audio Input and Output device. Tap the ROS icon at the top-left, then tap Sound & Video -> PulseAudio Volume Control. Tap the Output Devices tab, then tap on the check mark for the audio adapter that is your external USB Soundcard. Same for the Input Devices tab. Reboot System.

An external USB Microphone dongle is required for OAP to start up, however when using Bluetooth Audio on the Phone, or a device connected to the Phone for audio (such as your car), the USB Microphone dongle doesn’t appear to be used for voice, instead the microphone on the Bluetooth device seems to be used. I tested this with wireless headphones connected to my Phone, as well as the microphone built into my car connected to my phone via Bluetooth. However, OAP still requires an external USB Microphone dongle to function.

Google Assistant (Ok Google / Hey Google) requires data to perform some functions. When using Hotspot on OAP, normal WiFi functions are disabled. With the Phone connected to the Hotspot on OAP, you have to rely on Cell Data for Hey Google. There may be some lag in between commands as Google Assistant accesses the internet. This is a known issue with Google that others are experiencing outside of OAP.

There is a known issue in AA with Hey Google commands while music is playing, it will not always respond to you. When the music is paused, it will then respond to you. This also seems to be a random occurrence others experience outside of OAP.

My first inclination on setting up a new OS is to modify network settings to match my network. This was a mistake to do with ROS out of the box. I made so many network changes that I was unable to get Hotspot working with OAP because I set the ROS network to match my IP Address block of 192.168.1.X instead of using the default one that OAP uses which is 192.168.4.X. This caused the OAP Hotspot connection on my phone to loop through “Obtaining IP Address” indefinitely. Once I reflashed OAP with its unmodified default settings, and only setup the Wireless Hotspot connection out of the box, it worked. The initial ROS setup confused me about having to setup a WiFi connection so I started modifying settings when it didn’t work because Hotspot was on.

For best Wireless performance, OAP needs to be the WiFi Hotspot. Your phone needs to be the Client that is connected to the Hotspot. I’ve seen instructions conflating both methods, and I tried both. When the Phone is the Hotspot, performance is really bad. You can also modify ROS to connect to your normal WiFi Network without Hotspot and enable the AA Head Unit Server on your Phone to connect to the same network, but the performance is also really bad — plus you likely won’t be using this OAP head unit at home, but in your car.

The AA Wired Connection works well with a USB Hub connected to the RPi. I’ve been able to connect some of the external USB Devices to a small USB Hub that is connected to the RPi without issues, including the phone itself connected to the hub which also charges while the RPi is on.

For the best balance of Visual and Performance on my end, for both a Samsung Galaxy Note 8 and a Moto G7, in the OAP settings for AA -> Video, I have set the Resolution to 720p, FPS to 60 and DPI to 200. This gave me a nice crisp, clean, high res look with really good touch and drag performance both Wirelessly and Wired. In fact Wireless performance is almost as good as the wired, with just a few hiccups every so often.
USB Hardware I can confirm worked for me with these instructions:

USB Microphone: https://smile.amazon.com/gp/product/B01KLRBHGM
USB Soundcard: https://smile.amazon.com/gp/product/B07DBNFZJR/ (w/no Mic connected to Mic port).
USB Bluetooth: An unknown generic BT 4.0 brand I already had laying around for years.

Leave a Reply

Your email address will not be published.